まもなくWindows 7が発売になります。Windows 7では、Vistaの不満を解決する多くの改良が施されており前評判も上々です。Windows 7について書かれた記事はどれも歓迎ムードが漂っています。ところが「7」と名付けられたこのOSについて、なぜかWindowsのバージョン番号が6.1であるという疑惑が持ち上がっています。そこで、実際になでしこを使って簡単なプログラムを作って、Windows 7を検証してみたいと思います。バージョン番号の真相や特殊パスのロケーションなどを調べてみます。

Windows 7のバージョン番号を調べる

 何かと評判の悪かったWindows Vistaの失敗を踏まえた、Windows 7で注目できる部分を見てみると、それほどマシンパワーを必要としないことや、評判の悪かったUAC機能(特に画面を真っ黒にする確認画面)の改善、新しいタスクバーや、XPをエミュレーションするXPモードなどが挙げられています。

 いずれもとても楽しみな機能のですが、まずは、バージョン番号6.1という噂の真相を確かめてみなくてはなりません。そこで、Windows 7((評価版:ビルド7100)になでしこをインストールして検証してみました。ここでは、以下のようなプログラムを記述して実行しました。

文字サイズ=40
OSバージョンを表示。

やはりWindows7のバージョン番号は「6.1」だった!
[画像のクリックで拡大表示]

 結果はどうでしょうか。見事に「6.1」と表示されています。(ちなみにカッコの中はビルド番号を表しています。製品版ではこれより大きな数字になっているでしょう。)

 ちなみに、過去のWindowsのバージョンは以下のようになっています。98系は4.xで、2000系は5.x、そして、Vista系が6.xとなるのです。

Windowsの名称バージョン番号
Windows 984.0.1998
Windows 98SE4.10.2222
Windows Me4.90.3000
Windows 20005.0
Windows XP5.1
Windows Vista6.0
Windows 76.1

 そもそもなでしこのプログラム中で変数「OSバージョン」を参照することで、Windowsのバージョン番号を調べることができるようになっています。

 この番号を利用することで、ある特定のバージョンに依存したプログラムを作ることができます。もしも、動作対象を、Windows XP以上に限定したい場合は、次のようなプログラムを仕込んでおきます。(以下は、Windows XPより下のバージョンのWindowsで、警告メッセージを表示します。)

もし(OSバージョン<5.1)ならば
  「残念です。Windows XP以上でしか動きません!!」と言う。
  終わる。

この先は会員の登録が必要です。今なら有料会員(月額プラン)が12月末まで無料!

日経 xTECHには有料記事(有料会員向けまたは定期購読者向け)、無料記事(登録会員向け)、フリー記事(誰でも閲覧可能)があります。有料記事でも、登録会員向け配信期間は登録会員への登録が必要な場合があります。有料会員と登録会員に関するFAQはこちら