Windowsアプリケーションは、その中で利用する設定情報を、INIファイルかレジストリに保存することが多いです。

 例えば、Webブラウザーで、Internet Explorerに次ぐシェアを持つFirefoxも、ソフトの設定情報を、INIファイル形式で保存しています。

 そこで、今回は、INIファイルから情報を読み出して、これらのアプリケーションの機能を支援するようなアプリケーションを作ってみます。

 前々回、USBメモリにIEのお気に入りをコピーするプログラムを作りましたので、今回は、INIファイルから値を読み出す例として、Firefoxのブックマークをコピーするプログラムを作ってみたいと思います。

プログラム~Firefox 2 ブックマークのコピー

【使い方】

 以下のプログラムをなでしこエディタに貼り付け、実行します。
 すると、ブックマークを保存するフォルダーを尋ねられます。
 フォルダーを選ぶと、bookmarks.html という名前でブックマークをコピーします。

【プログラムソース1】

#-----------------------------------------------------------
# Firefox 2 ブックマークのコピー
#-----------------------------------------------------------
#
FXパス=「%APPDATA%¥Mozilla¥Firefox¥」の環境変数展開。
INIパス=「{FXパス}profiles.ini」
# インストールチェック
INIパスが存在するか?
もし、それがいいえならば
  「Firefoxの設定が見つかりませんでした。」と言う。
  終わり。
# ブックマークのパスを調べる
INIパスのINI開いてハンドルに代入。
ハンドルで「Profile0」の「Path」をINI読む。
それの「/」を「¥」に置換して、個人パスに代入。
ブックマークパス=「{FXパス}{個人パス}¥bookmarks.html」
ブックマークパスが存在するか?
もし、それがいいえならば
  「ブックマークが見つかりませんでした。」と言う。
  終わり。
# コピー
「保存するフォルダを選択してください。」と言う。
フォルダ選択して保存パスに代入。
ブックマークパスから保存パス&「bookmarks.html」へファイルコピー。
「コピー完了です」と言う。
終わり。
#-----------------------------------------------------------

[ではプログラムの中身を見ていこう:次のページへ]

この先は会員の登録が必要です。有料会員(月額プラン)は初月無料!

日経 xTECHには有料記事(有料会員向けまたは定期購読者向け)、無料記事(登録会員向け)、フリー記事(誰でも閲覧可能)があります。有料記事でも、登録会員向け配信期間は登録会員への登録が必要な場合があります。有料会員と登録会員に関するFAQはこちら